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Disclaimer of Warranty

USING THIS SOFTWARE INDICATES YOUR 
ACCEPTANCE OF THE FOLLOWING TERMS AND 
CONDITIONS.  IF YOU DO NOT ACCEPT THESE 
TERMS AND CONDITIONS DO NOT USE IT.

Even though Epsilon Systems has tested the software and 
reviewed the documentation, THE PROGRAM IS 
PROVIDED " AS IS "  WITHOUT WARRANTY OF ANY 
KIND, EITHER EXPRESSED OR IMPLIED.  YOU 
ASSUME THE ENTIRE RISK AS TO THE QUALITY 
AND PERFORMANCE OF THE PROGRAM.  SHOULD 
THE PROGRAM PROVE TO BE DEFECTIVE, YOU 
ASSUME THE ENTIRE COST OF ALL NECESSARY 
SERVICING, REPAIR OR CORRECTION.

IN NO EVENT WILL EPSILON SYSTEMS BE LIABLE 
FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR 
CONSEQUENTIAL DAMAGES, RESULTING FROM 
ANY DEFECT IN THE SOFTWARE OR ITS 
DOCUMENTATION.  EVEN IF EPSILON SYSTEMS HAS 
BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES.
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Chapter 1: Getting Acquainted

About MacLibrarian

MacLibrarian is a disk management and a disk labeling 
program.  You can create professional looking labels for 
your library of disks by simply drawing a template and then 
letting MacLibrarian fill in the areas such as disk name, 
serial number, file name and more.  If you want to add 
pictures to your labels then simply define the area and paste 
the picture into the area.  It has never been simpler!  

You can also use it to find a particular file on a disk 
(including the disks that have been sitting around in your 
desk or filing cabinet).  It is ideal for recovering wasted 
space taken up by duplicate files and extremely old versions 
of files.  It searches and sorts on file name, date created or 
modified, file type, file creator, file size, application memory
size, version, disk number, and disk name.  In addition, it 
recognizes StuffIt and Compactor archives and optionally 
expands their contents.  

This program has saved me many hours of trying to locate a 
file that resides somewhere in the 200 plus disks that I have 
in my desk.  With MacLibrarian I am now able to locate a 
file within seconds and load the proper file onto my hard 
disk (40 megabytes for a hard disk is just not enough).  All I 
had to do to get started, was to insert the first disk, then the 
second, third... and so on.  MacLibrarian scans each disk, 
ejects it and waits for the next one.  When your are done 
scanning the disks, click Done and MacLibrarian builds a 
library; it's that simple!

How about printing some professional looking labels?  
MacLibrarian 1.5.4 allows you to define templates for any 
label size (from 1.00" x 1.00" to 2.75" x 4.00") and page 
format.  Creating templates is as easy as drawing with any 
draw program.  You can create designs that are both 
functional and attractive.  Sample template designs for the 
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LaserWriter and ImageWriter are provided for your 
convenience, feel free to use them or create your own.

When printing labels (version 1.5.4) requires a personnel 
key to remove the message over each label.  This personnel 
key is issued to all registered users.

To ensure that you start on the right footing and take 
maximum advantage of MacLibrarian you should read the 
next few pages.
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Distribution and 
Usage

MacLibrarian 1.5.4 is being offered for distribution under 
the shareware philosophy and is copyrighted © in its entirety
by Epsilon Systems.  If you decide that it is of no use to you 
and do not want to keep it, please destroy your copy or pass 
it on.  Otherwise, you are required to register within 10 days 
by filling in and sending the form in appendix A with your 
registration fee of US $30.  

Registered users will receive a personnel key which does not
print a message over each label printed.  In addition, 
registration will entitle you to bug fixes and future 
enhancements.

I am looking for other useful features to add to 
MacLibrarian so take a few moments and tell me what you 
would like to see added.  Commercial distribution of 
MacLibrarian requires a licensing agreement please contact 
Epsilon Systems.  

What you need

Inventory

The MacLibrarian package should contain the following:

• MacLibrarian 1.5.4 application
• LaserWriter-Label Templates
• ImageWriter-Label Templates
• MacLibrarian User guide (this document)
• ReadMe files.
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Hardware and 
software 
requirements

MacLibrarian runs on any Macintosh computer with 1 
megabyte of memory and a hard disk.  MacLibrarian has 
been tested on a Mac SE, Mac II, IIci and Quadra 700  
running under version 6.0.5 and 7.0.1 of the operating 
system.  In addition it has been fully tested scanning 
SyQuest, CDs, hard disks and regular floppies.

MacLibrarian is designed to work with a single floppy and 
hard disk system; however, there is no reason why it should 
not function as designed with a two floppy system.  The two 
floppy system is untested and is used at your own risk.
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What you should 
know

MacLibrarian is a disk management program.  Although 
MacLibrarian has attempted to automate all functions of 
disk management, there are a few things that you still have 
to do to manage your disks.  

There are two ways to successfully manage your disks:

1. Managing by serial numbers:

You need to physically mark each disk with a serial 
number as assigned by MacLibrarian when you scan each
disk.  Physically marking each disk with a serial number 
and storing the disks in sequential order will help you in 
finding the proper disk when you need it.  The serial 
number is a maximum of three digits which starts from 
zero and is incremented as each disk is scanned.  If you 
delete a disk from your library then the next available 
serial number is assigned to the next disk scanned.  The 
serial number is the unique identifier for the disk.

2. Managing by Disk names:

To manage your disks by name you need to store your 
disks in alphabetical order.  This allows you to retrieve 
the desired disk when required.  However, if you have the
habit of having duplicate names for disks such as 
'Untitled' then you may have to make several attempts to 
find the right disk.  Several people have indicated this is 
the method they prefer.  Obviously, the choice is yours.

MacLibrarian can optionally stamp the disk (see the Stamp 
Disk Electronically preference) which creates an invisible
file on the disk.  The advantage of stamping the disk 
electronically is that you can identify your disk by inserting 
it and letting MacLibrarian find out its serial number.  In 
future versions, MacLibrarian will provide additional 

MacLibrarian User Guide



Table of Contents 13

features that use this invisible file.
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Glossary of terms

Throughout this manual there is terminology used which 
you need to be familiar with.  The following is a list of the 
terms used.

•  Stamped disk: A scanned disk containing an invisible 
file.  This invisible file contains the serial 
number, date last scanned and other 
information for quick identification of the 
disk by MacLibrarian.

•  Disk record: The information scanned on each disk.  The 
disk record includes the disk name, serial 
number, locked disk, stamped disk indicator, 
date created and modified, size, number of 
files and directories, and type of disk.

•  File record: The information scanned on each file.  The 
file record includes the file name, serial 
number of disk, type (application, document 
or folder), date created and modified, Type 
and Creator signatures, and version number 
of the application.

•  Disk library: The entire collection of disk records.

•  File library: The entire collection of file records.

•  Library: The MacLibrarian document file which 
contains all the disk and file records.

•  View window: The window containing the disk or file
records.

•  View title: The title of each column in the View window.

•  Tree: A pictorial representation of the hierarchical 
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file system showing all branches and contents
of the directories on the disk.

•  StuffIt file: Archive utility that compresses many files 
into a single file.

•  Compactor: Archive utility that compresses many files 
into a single file.

•  Serial number The number assigned to the disk when 
scanned by MacLibrarian.  Disk and serial 
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numbers are interchangeable terms and are used throughout 
this manual.

•  Page Layout A template which defines the label page 
format, for example the number of labels per 
page, size of labels, spacing between labels 
and other attributes.  Do not confuse this with
Page Format.

•  Label Layout A template which defines the object 
attributes for  the label.  Typical objects are 
Picts, static text, drawing objects, file 
contents of the disk and each of the disk 
records.

•  Label template The combination of the Page Layout 
and Label Layout.  

Conventions used in 
this document

Menu commands and keywords appear in bold throughout 
this manual.
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Chapter 2: Exploring MacLibrarian Menus

There are six menu titles in the MacLibrarian 
menu bar.  These are: Apple, File, Edit, 
Librarian, Preferences, Windows.  Each menu 
is briefly described below.

Apple Menu

The Apple menu lets you to access your Macintosh system desk 
accessories.  The About MacLibrarian menu item summarizes 
MacLibrarian capabilities and provides additional information for non 
registered users.  It also tells you which version of MacLibrarian you are 
using.  

File Menu

The File menu is similar to the other File menus in Macintosh 
applications.  You can create a new library, open an existing library, close 
the active window, save the library, save it to another file, or revert the 
library to the last saved version.  This menu also lets you control your 
printed output by setting your margins in the Page Setup menu item.  It 
can also optionally print part of the library or the entire library.  You can 
exit from MacLibrarian by selecting the Quit menu item.

The File menu also allows you to export all or part of your library as tab 
deliminated text.

You can also create, modify and save label templates and print disk labels 
for selected disk records.  
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Edit Menu

The Edit menu is similar to other Macintosh applications.  However, its 
behavior is slightly different from text documents for example, you cannot
paste into the disk record area since the library has to represent what is on 
the actual disk.  

There is a chapter devoted to editing and you should take the time to 
familiarize yourself with the minor differences.  

Librarian Menu

The Librarian menu lets you scan a new disk into the library or update 
your library if changes have been made to your original disk.  It also 
allows you to identify a disk and its location in the library by simply 
inserting it (assuming the stamp preference is enabled).  You can delete a 
disk from the library, or permanently delete all disk records marked for 
deletion by using Tidy.

You can also sort on any field and search for a string or date for which the 
disk or file was created or modified.  The available sort and search 
hierarchical menus change for each MacLibrarian window.  
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Preferences Menu

The Preferences menu allows you to change the behavior of MacLibrarian 
to suit your needs.  It lets you set MacLibrarian in Auto Sort and Auto 
Tidy mode.  Auto Sort sorts the column moved to the first column 
position and Auto Tidy automatically updates the library any time a disk 
record is marked deleted.

You can select the internal drive as the only drive to be scanned by 
enabling Fast Scan or you can select any mounted drive by disabling 
Fast scan.  In addition, you can expand the contents of archives when 
scanning your disks.  StuffIt, StuffIt Classic, StuffIt Deluxe and 
Compactor archives are supported.

You can enable the ability to cancel Scan operations by using CMD-'.' 
(Period).  Disabling this feature reduces MacLibrarian memory usage and 
requirements.

You can disable the feature that stamps your disks electronically with a 
serial number and other pertinent information or you can enable it and take
advantage of the feature that allows you to identify your disk.

You can enable or disable the ability to display a dialog box asking for 
confirmation every time you delete a disk from the library.

You can also apply a filter to the files that you don't want displayed or 
printed.  In addition, you can optionally display a grid in the Disk and 
File windows and adjust the size and spacing of the icons displayed in the 
Tree window.  

Window Menu

The window menu lets you access the online help, the clipboard, and Disk
and File windows.  In addition, all open windows are listed in the menu 
for quick access to the proper window.  

MacLibrarian User Guide



Table of Contents 20

Chapter 3: Getting started with MacLibrarian

Before you get 
started

Please read the following notes before you start using the 
new version.

Copy the contents of the disk supplied into a folder on your 
hard disk before you start. 

If you already have a library built with version 1.0 and 
would like to continue using it with version 1.5.4 then 
follow the instructions below otherwise, you may skip the 
next section "Converting your libraries." 

Converting your 
libraries

Your old libraries are no longer compatible with the new Library format.  
A new format was required because MacLibrarian is now memory-based 
instead of disk-based.  This means that among other things it searches and 
sorts much faster.  To use your old library you need to convert it using the 
Converter 1.0->1.5 application.  Registered users may contact Epsilon 
systems to get access to this application.

To convert your library to the new format:

1. Double-click the Converter application.

A file dialog box is displayed.  
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2. Double-click on your version 1.0 library.

The Converter reads you old library into memory and 
displays a new dialog box.

3. Enter a new library name (do not use the version 1.0 
name) and click the Save button.

Converter saves your library in the new library format 
and returns you to the Finder.

Setting memory 
requirements

MacLibrarian memory requirements are set at 700K.  This 
should be enough for loading a single library.  If you need to
open many libraries simultaneously, increase the memory 
requirement to 1000K by first selecting the MacLibrarian 
application and then selecting the Get Info menu item from 
the File menu in the Finder.
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Starting MacLibrarian

As described previously, MacLibrarian is designed to work 
from your hard disk.  Please copy the disk contents of your 
disk to a folder on your hard disk.

MacLibrarian 1.5

To start MacLibrarian 

• Double-click the application icon (  ).

MacLibrarian goes through its initialization procedure and opens with an 
Untitled0 - Disk window.  You are now ready to build a new library or 
open an existing one.  

Note: If you plan to stamp your disks electronically you should save the 
library before scanning any disks into the library.  One of the new features
is that stamp files now holds information about the library which the disk 
belongs to.
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To create a new library 

1. Select the New menu item in the File menu.  

MacLibrarian will create a new Untitled## - Disk 
window.  Where ## is a sequential number assigned to 
distinguish it from other libraries which have not been 
saved to disk yet.  You can create as many new libraries 
as desired.  There is no limit except the amount of 
available memory.

2. Select the Save menu item in the File menu.  

A dialog box is displayed asking you to save the library.

3. Enter the desired filename and click Save.

This copies your library from memory to your hard disk.  
All your window settings, the window position on your 
desktop and the preference settings are also saved.

You can now build your library by scanning your disk 
collection.

To open a library document

1 Select the Open menu item in the File menu.  

MacLibrarian displays a dialog box showing all the files it recognizes.  
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2 Select the desired file and click Open.

MacLibrarian displays a progress dialog while loading 
the desired library.  If this is a new library that has been 
converted from version 1.0 then MacLibrarian opens the 
library in the default mode (that is, the disk window is 
opened with the default preferences.).  If this is a 
previously opened library then the library will be opened 
with the same preferences and all previous windows 
restored.

To override the preferences when opening a library

• Hold down the option key when opening the library.

MacLibrarian ignores all preference settings and 
previously saved window positions and opens only the 
Disk window.  All preferences are set to the default. 

Note: You can load a library by double-clicking the 
appropriate library document from the Finder.
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Building a library

There are two ways to build a library: Fast Scan or Scan Disk.  The 
major difference is that Fast scan is designed to scan many disks in a 
short time.  Thus, it is limited to the internal drive.  Scan disk, on the 
other hand, is designed for flexibility and allows any drive to be selected 
and scanned.  This includes optical drives, CDs, hard drives and other 
floppy drives.  

It is a good idea to scan a few disks at a time and to save your document 
regularly.  This way you avoid losing your data from system malfunctions 
during your working session.

Fast Scan is the default mode of operation at start-up.  

You need to be aware of the feature Stamp Disk, which stamps each disk
electronically before scanning your disks.  This feature does assume that 
the disk being scanned is not locked since it does need to write to the disk.
However, if you insert a locked disk, MacLibrarian will eject the disk and 
inform you that its locked.  You may now unlock it or leave it locked and 
re insert the disk.  If you leave it locked then MacLibrarian will not be 
able to stamp the disk.  For further details see the section on Stamp Disk 
Electronically.

Building a library 
with fast scan

To build a library using FastScan 

1. Select Fast Scan from the Librarian menu.  

A Fast Scan dialog is displayed.  If a disk is in the 
internal drive it is ejected.  
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2. Insert the disk to be scanned.
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An information dialog is displayed showing the number 
of files scanned and the name of the file being scanned.  
In addition, a bar is presented to give you an indication of
the progress.

Upon completion of the scanning operation, the 
information dialog is removed, the contents of the disk 
are added to the library, and the disk is ejected.  In 
addition, the Serial number assigned to the disk is now 
displayed in the dialog box.

3. Repeat step 2 for all other disks.

If you have other disks to be scanned then simply insert 
them one after the other.  

4. To exit scanning mode click Done.

Note: You can cancel the scan operation by using CMD-'.' 
(Period).  This feature can also be disabled to save 
memory by  disabling CMD-Period Enabled menu 
item in the Preference menu.  For further details see 
the section on Customizing MacLibrarian.

MacLibrarian User Guide



Table of Contents 29

Building a library 
with Scan Disk

To use the Scan Disk option you first need to disable Fast Scan.  If you
are unsure how to do this, see the section on Customizing MacLibrarian.  
The Fast Scan menu changes to Scan disk indicating that you have 
disabled Fast Scan.  

The Scan Disk option lets you scan a single disk at a time.  However, it 
does allow other drives besides the internal floppy to be scanned.

To build a library using Scan Disk 

1. Select Scan Disk from the Librarian menu 

A scan dialog is displayed as shown below.  
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The scan dialog has a pop-up menu for selecting the 
desired drive and a visual indicator showing the type of 
drive.  If the drive is of a type that can be ejected the 
Eject button is enabled.

2. Select the desired drive name from the pop-up menu.

3. Click the Scan button.

An information dialog is displayed showing the number 
of files scanned and the name of the file being scanned.  
In addition, a bar is presented to give you an indication of
how much progress has been made.

Upon completion of the scanning operation the 
information dialog is removed, the contents of the disk 
are added to the library.  In addition, the Serial number 
assigned to the disk is now displayed in the dialog box.

3. Repeat from step 1 for all other disks.

If you have other disks to be scanned then simply select 
them one after the other.  
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4. To exit scanning mode click Done.

Note: You can cancel the scan operation by using CMD-'.' 
(Period).  This feature can also be disabled to save 
required memory by disabling CMD-Period Enabled 
menu item in the Preference menu.  For further details 
see the section on Customizing MacLibrarian.
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Identifying a disk

To identify a disk you need to have stamped the disk during 
scan.  To stamp a disk you need to enable the Stamp Disk 
menu item in the Preferences menu.  When you  stamp a 
disk, an invisible file containing the library name, disk 
name, serial number, date created, date modified and date 
stamped is written to the disk.  Since the stamp disk feature 
now saves the library name, you need to ensure that a valid 
and meaningful name exists for your library before stamping
your disks.  This will become more important in future 
versions.  For further information on stamping disks refer to 
chapter 9.  

To identify a disk that has been stamped 

1. Select  Identify menu item from the Librarian menu.

A dialog box is displayed.  If a disk is present in the 
internal drive the Eject and Identify buttons are 
enabled.

2. Insert a disk to be identified and click the Identify 
button.
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The invisible file is read from the stamped disk and the 
dialog is updated with the appropriate information.  

3. To exit the dialog click the Cancel button.
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Identifying version 
1.0 stamped files

You can identify disks that have been electronically stamped
as per version 1.0.  The difference is that the Library name 
of the file is not displayed.  There is no need to re-stamp all 
your disks since this feature is only used to identify the disk.
However, in future versions more use of the stamp file will 
be made.  New scans or updates will be stamped as per 
version 1.5 and will include the Library name of the stamped
file.

Opening a library 
document

There are two ways you can open a library file:  from a 
menu or from the desktop.  You can now have many libraries
open simultaneously; the only limit is the amount of 
memory available to MacLibrarian.  

To open a library file from the desktop

1. Double-click the library document file.

MacLibrarian undergoes its initialization procedure and 
upon completion displays the windows in the last 
position when the library was saved.  In addition, the 
library preference settings are also set to the settings prior
to the last save.
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To open a library file from the menu

As indicated previously you can now have many libraries open 
simultaneously.  

1. Select the Open from the File menu.

A dialog showing the library files MacLibrarian recognizes is displayed.  
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2. Select the desired library file.

3. Click the Open button.

MacLibrarian undergoes its initialization procedure and 
upon completion displays the windows in the same 
position when the library was last saved.  In addition, the 
library preferences are restored to the same conditions 
before the last save.

Note:A short cut is to double-click the library file to be 
opened.

Managing multiple 
libraries

MacLibrarian now allows you to have more than one library 
open at a time.  Note that preference settings are library 
based; that is, they belong to a particular library.  If you 
want the same preference settings for all your libraries you 
have to set them for each library.  

When you save a file it remembers your preference settings, 
the windows open, Window positions and selected items 
within the window.  

If you close a Disk window for a particular library, then all 
other windows associated with the library are closed.  The 
only time you are asked for confirmation to save is when 
you scan, update  or delete a disk.  Changing preference 
settings, will not ask you to confirmation for "save 
changes?".

Preference override

You can override the file preference settings when loading 
the library.  Overriding the preference settings will open the 
library in the default mode.  That is all preferences are set to 
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the default, no filters are applied and the disk window will 
open in the default position.

You can override the preferences being loaded by holding 
down the option key while the library is being loaded.
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Closing the library 
file

To close a library document without quitting MacLibrarian 
you must close the Disk window.  To close a window, select
the Close menu item from the File menu.  A more 
convenient method is to click in the close box.

Close Window Box Zoom Window Box

If changes have occurred since the last save, a dialog box 
appears asking you if you want to save the changes.  

Saving library files

During your session MacLibrarian works on a copy of the 
library file in memory.  All changes are temporary until you 
save the changes for the session.  You can save the changes 
into the original library file or save them to a new library 
file.  If you plan to save to a new library file then you should
be aware that your original stamped files will not be updated
and will hold the original library name.

To save changes to the library document

1. Select Save from the File menu.

MacLibrarian will update the contents of the original 
library document with all the changes that have occurred 
since the last Save.  It also saves all the preference 
settings, all open windows and their respective positions, 
the selected items, scroll bar position and all view 
settings.

To save changes to a new library file

1. Select Save As from the File menu.

A familiar Save Dialog is displayed as shown below.
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If you change your mind click the Cancel button to 
ignore the Save As command. 

2. Select the desired drive and directory.

If you are unfamiliar with moving about directories or 
changing the drive you should consult the manual that 
came with your system.

3. Type the new name of the library file.

4. Click the Save button.

MacLibrarian creates a new library file and saves it with 
the name you typed in the dialog box.  It updates all the 
open windows of the library to reflect the changes.  

Note Be careful when changing the name of the library 
especially if you have stamped your disks.  The stamp 
disk feature now saves the library name for the disk 
scanned.  There is no way to change the contents of the 
stamp file without an Update.

Reverting to the last 
saved library file

One of the features of MacLibrarian is the ability to revert to
the last saved library.  This is especially useful if you change
your mind after making lots of changes.  The revert features 
combines several operations into a single command.
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To revert to the last saved library file

• Select Revert from the File menu.

All changes since your last save are discarded.  
MacLibrarian initializes itself and prepares the library 
file for use. 
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Quitting 
MacLibrarian

To end your working session

1. Select Quit from the File menu.

If changes have been made to your library document 
since your last save, MacLibrarian displays a dialog box 
asking if you want to save the changes.  The changes 
mentioned above refers to major changes that effect the 
content of your library and not to scroll bar settings, 
selected items, window position, view titles or other 
preference settings.  

Clicking:

Yes saves the changes to your library file and quits the 
MacLibrarian application.

No ignore all changes to your library file and quits the 
application.

Cancel ignores your request to quit from MacLibrarian.

Before MacLibrarian quits it performs some housekeeping 
and releases all the memory it used.  
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Chapter 4: Getting Help

MacLibrarian provides online help.  The online
help is a condensed version of this document 
and assumes that you are familiar with 
MacLibrarian but have forgotten some details. 
It is not meant to replace this document.

To get online help, select the Help menu item 
in the Windows menu.  This loads the help 
file and displays the dialog box as shown 
below.

The dialog box has a popup menu, scroll bar 
and an OK button.  Selecting the popup menu 
displays a list of the help topics and the scroll 
bar allows you to scroll through the help file.  
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Viewing help topics

To review the help topics select the pop-up menu at the top 
of the dialog.  A list of available topics is displayed.  

To view contents not currently being displayed, move the 
cursor to the bottom while holding the mouse button down.  
The list scrolls up.
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Selecting a topic

Select the desired topic.  The help text is displayed in the 
window.  Use the scroll bar to move through the text.  

When you are done with the help file, click the OK button.  
You are returned to the window you were at before entering 
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the help dialog.

MacLibrarian User Guide



Table of Contents 46

Chapter 5: Labelling Your Disks

Before you can print a label you need to select 
the disk records of the disks you want to label 
from the disk window.  Use the Labels menu 
item in the File menu of the disk window to 
create label templates, save the templates, load 
predefined templates and print labels.  Some 
predefined label templates are included, you 
can modify these or create your own.

The label template consists of two 
components: a page layout and a label layout.  
The page layout component of the template is 
what makes the labeling component of 
MacLibrarian so flexible; you do not need to 
stick to a specific manufacturer of disk labels.  
You simply measure and define your own 
template.

Labelling your disks

Select the Labels menu item from the File menu to display 
the label dialog.
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This dialog has two views.  The first known as the page 
layout, shown above, lets you define the label width and 
height, the vertical and horizontal spacing between labels, 
the number of labels across and down a page, and the page 
margins.  You can use the editable text fields or the graphical
representation of the label page to define these values.  
Selecting 
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solid lines other than the border lets you graphically change 
any of the label page formats (the exception is the number of
labels across).  

The second view known as the label layout (shown below)
lets you define the graphics you want included in the label.  

You can toggle between the two views of the dialog by 
clicking the Switcher icon  at the top of the tool area.   
The OK button also takes you to the label layout screen 
from the page layout, but once in the label layout screen it
will not bring you back to the page layout screen.  Instead,
it will assume that you have finished and will return you to 
the calling Disk window.  However, your information is 
not lost and will be available the next time you return to the 
label dialog.  This is useful if you forgot to select the disks 
to be labeled or need a picture and have not copied it to your
clipboard.

Creating objects on 
your disk label 

You can create objects using the tool palette, MacDraw 
style, or by using the views at the top of the dialog box.  
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There is a maximum limit of 99 objects that you can place 
on your labels.  If you need more than 99 objects than you 
should design the object using a paint or draw program and 
paste it as a pict.  
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The tool palette

You can create objects using the tool palette, MacDraw 
style.  The tools in the tool palette are similar to those 
available with other drawing packages.

Used to switch between the 
label template and label 
page format.Pict Tool used to 

define area to paste 
picture into.

FileTool - similiar to 
views but creates a 

column of file names for 
the topmost directory

Pen Size tool - 
select the desired 

thickness.

Text tool

Drawing tools

The switch tool lets you switch between the two views for defining a 
label template (the page layout and the label layout).  

The pict tool lets you define an area on the label to paste a picture from 
another application.  It will rescale the vertical and horizontal size of the 
picture to fit in the enclosed rectangle.  

To paste a picture, select the pict tool and draw the area for the pict to 
reside.  With the area rectangle selected use Command-'V' to paste the 
picture into the area.  Note that your picture will be rescaled to fill the area
defined.  To regain the correct aspect ratio you need to ensure that the area
defined is of the correct aspect ratio.  You can double click to change the 
size and location attributes of the pict.  See Changing attributes.  

The file tool lets you define an area on the label in which to print a 
column of names of the contents of your disk.  Note only the top-level 
names of the disk contents are printed.  If the names do not fit in the 
defined area, you can define a second area (or as many that will fit) beside 
the first.  
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You can define more than one file object on the label.  MacLibrarian keeps
track of the filenames already printed and continues from where it left off 
on the first column.  This is useful if you want to print two or more 
columns of filenames on your label.  

The text tool lets you define an area to display your static text on the 
label.  Select the text tool and draw a rectangle where your text will go.  
To change the text double click the text tool and you will be presented 
with a dialog box allowing you to change the text and other attributes 
associated with this object.

The line around text objects does not get drawn and is there as a guide.  

The line tool lets you draw lines on your label.  The line tool draws in the
current selected line thickness.  To draw a line select the line tool and click
and drag from the start to the end point.  

The straight line tool lets you draw straight lines in the vertical or 
horizontal directions only.  Its operation is similar to the line tool.  

The rectangle tool lets you draw a rectangle any where on the label 
layout.  To draw a rectangle, select the rectangle tool and click and drag 
from the start corner to the diagonally opposite corner.  To change the 
attributes of the rectangle see the section on changing attributes.  

The rounded rectangle tool lets you draw a rounded corner rectangle.  
Its creation is similar to the rectangle tool.  

The circle tool lets you draw a circle in the label layout.  Its creation is 
similar to the rectangle tool.  

The arc tool allows you to draw an arc.  To draw an arc select the arc tool
and click and draw from one end to the other end.  You can change the 
attributes of the arc by double clicking on the arc.  See changing attributes 
section.  

There are eight line thicknesses you can use with the above tools.  
Select the desired line thickness by clicking on the line thickness.  The line
will be used for subsequent operations.

It is sometimes desirable not to have a border, to remove a border double-
click the object and set the line thickness attribute to zero.  See changing 
attributes for further details.
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Putting Library 
information on your 
disk label

You can include disk information from your library on your 
label.  Select the View item from the table at the top of the 
label layout (for example, Num, Stamped) and drag it 
anywhere on the label.  When you print the label the value 
of the view item is substituted from your library.

To place library information on the label

1. Click and drag the view item desired.

An outline of the desired item will track the mouse.

2. Release the mouse button in the position you would like 
the view item to appear on the label.

The view item object is placed on the label.  You may 
now resize the object and change the attributes of the 
object.

The line drawn around the view item object does not get 
drawn when the label is printed.  You can change the object 
size to accommodate the view item (volume names can be 
28 chars long) otherwise, the text will get truncated.  
Truncation is indicated by three periods placed at the end the
visible text.

Stamp or locked view items will draw icons to fit the object 
area.  Therefore, for best results make the object rectangle a 
square.
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Once you have dragged a view item to the label, you don't 
have to delete it and drag another item if you want to change
it.  You can double-click the view item object and change the
view item from the Show pop-up menu (see changing 
attributes).  You can also change other attributes such as the 
object rectangle, background pattern, Font size, style and the
font used.

Changing attributes

Each object has many attributes associated with it (e.g. area, 
background patterns).  Not all the attributes are available to 
all the objects, for example, it does not make sense to have a
font attribute with pict objects.  You can change the 
attributes for each object to get the desired look.

Changing object 
attributes

To change the attributes to an object

1. Double-click the object.  

You will be presented with a dialog.  

2. Use the dialog to change the attributes of the object.  
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You can change the following attributes: the background 
pattern of the object, the position of the object, the font, 
the font size and style (if applicable), and the pen size for
the border of the object (if applicable).  
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Note: When the pen size is set to zero, the border is not drawn 
around the object.  The borders surrounding text is for 
display purposes only.  

Deleting objects

To delete an object 

1. Select the object

Selected objects are indicated by handles.

2. Press the delete key on your keyboard.

The object is removed from the list and is no longer 
displayed.

Moving objects to the
background and 
foreground

Like many other draw applications you can move an object 
to the foreground or background.  

To move an object to the foreground

1. Select the object. 

2. Press the Up arrow key on your keyboard.

The object remains selected but it is now behind all other 
objects.

To move an object to the background

1. Select the object 

2. Press the Down arrow key on your keyboard.

The object remains selected but it is in front of all other 
objects displayed.
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Saving and retrieving
label templates

Once you have defined your template you can save it.  

To save a template

1. Click the Save Tmplt button in the Label dialog. 
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You will be presented with a file dialog.

2 Enter a filename for the template you wish to save.

3. Click the save button

The dialog is removed and the label information is saved 
to the label document.

To load a template

1. Click on the Load Tmplt button in the Label dialog.

You will be presented with a file dialog.

2. Select the desired template.

3. Click the open button
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The label template information is loaded into memory.
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Printing

Before you can print your labels you need to have selected a 
disk record and either loaded a label template or defined 
your own.  Part of the information that is stored with the 
templates is the Page Setup information.  You need to set the
page format as described in the next section for best results.

Page format

As mentioned earlier you need to set the page formats for 
maximum label area.  Any object that lies outside the 
printable area does not get printed.  The reason for this is 
that some printers may get damaged if you print outside the 
printable area.  Therefore, MacLibrarian checks for any 
object that lies outside the printable area and ignores it.  
Most Laser printers have the ability to enlarge this area and 
you need to set the option Larger Print Area to use most 
commercial disk labels.

To enlarge the print area

1. Click the format button.

You will be presented with the standard page setup 
dialog.

2. Click the Options button in the Page Setup dialog.

You will be presented with an options dialog
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3. Click the Larger Print area (Fewer Downloadable Fonts)
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An 'x' appears in the check box.

4. Click the OK button in the Options dialog.

5. Click the OK button in the Page Setup dialog.

Printing your labels

Before you print any labels, test your templates on regular 
paper.

The following pictures are for a laser printer.  If you are 
using an ImageWriter then the dialogs displayed will be 
different.

To print your labels

1. Click the Print button.

You will be presented with the following dialog.  

The dialog allows you to select the start position for 
printing.  The number of rectangles displayed depends on
the total number of labels defined in your template.

2. Select the start position for the label to be printed and 
Click the Proceed button.

You will be presented with the following dialog.
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You may select the desired options as required.  
However, you should be aware that Copies on 
LaserWriter refer to pages of labels and not to individual 
labels.  On an ImageWriter Copies refer to the number 
of copies of each label you want printed.

3. Select the number of copies required and Click on the 
Print button.

Status information is presented while MacLibrarian 
prepares the labels for your printer.
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Chapter 6: Editing

Correcting mistakes

It is assumed you are already familiar with the editing functions of the 
Edit menu on your Macintosh.  MacLibrarian handles these like any other
application; however, the Undo function may not be so obvious.  When 
you Cut or Clear a disk record the disk is not removed from the library 
but is marked deleted (assuming you are not in Auto Tidy mode).  

dimmed disk record marked deleted

You can easily identify a disk which is marked deleted by 
the way it is displayed.  The disk record is shown dimmed 
and is not removed from the library until a Tidy is done.  
The Tidy function scans the library and removes all the 
disks that have been marked for deletion.  This provides 
another level of protection and allows you to retrieve files 
that have been marked for deletion.  If you would like to 
disable this feature then turn on the Auto Tidy preference 
which is further described in Chapter 9 "Customizing 
MacLibrarian".

To undo (retrieve) a deleted disk record

1. Select the record that is marked deleted.

A disk record is marked deleted if it is dimmed.

2. Select Undo from the Edit menu.

The disk record is retrieved and no longer appears 
dimmed.

Note: MacLibrarian works on a copy of your library therefore 
editing functions do not become permanent until you 
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save your library file.
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Deleting records

There are several ways for you to delete disk records.  You 
can use Cut, Clear and Delete Disk with or without Auto
Tidy enabled.  With Auto Tidy enabled you can bypass the 
dimmed (marked for deletion) records and delete the records
directly.  However, you are warned that you are in Auto Tidy
mode.  This warning can also be disabled (see Ask before 
delete in "Customizing MacLibrarian").

When you delete a disk record you are removing the disk 
information with all the file records associated with the disk 
record from the library.  To ensure the integrity of your 
library, you are only permitted to delete disk records.  If it 
was possible for you to delete a single file record then the 
disk record would not be accurate.  

There are two ways you can delete disk records with Auto 
Tidy disabled.

To delete a disk record using Delete Disk

1. Select the Delete Disk from the Librarian menu.

A dialog is displayed asking for the disk number (serial 
number).

2. Enter the disk number (serial number) you wish to 
remove from the library.

3. Select the OK button.

The dialog box disappears and the disk record is dimmed 
to show that it has been marked for deletion.  In addition,
all file records associated with the disk record are also 
dimmed to show that these files are marked for deletion.  

4. Select Tidy from the Librarian menu.

All the dimmed records are removed permanently from 
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the library file and the windows are updated.

The records dimmed are only marked deleted and are not 
removed from the library until a Tidy is done.  The shading 
and marking of deletion records can be optionally bypassed 
by adjusting the Auto Tidy preference as described in 
"Preferences when deleting" further on in this chapter.
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To delete a disk using Cut or Clear

Version 1.5 now lets you delete multiple records.  You can 
delete multiple records by selecting all the desired records 
and following the procedure below.

1. Select a record by clicking on it.

This operation is required to identify the disk record.  
You can click on a disk record or a file record.  If a file 
record is selected MacLibrarian finds the disk record and 
deletes it with all the associated file records.

2. Select a Cut or Clear from the File menu.

The selected records for the file and disk are dimmed to 
show that it is marked for deletion.

3. Select Tidy from the Librarian menu.

All the dimmed records are removed permanently from 
the library file and the windows are updated.

Preferences when 
deleting

As previously described the disk and file records are marked
for deletion and are shown by the dimmed records.  This is 
only true if the Auto Tidy preference is disabled.  

If the Auto Tidy preference is enabled the actions taken by 
MacLibrarian are very different.  The records are deleted 
immediately.  You are warned that you are in Auto Tidy 
mode and are given the option of backing down.  You can 
disable this warning by the Ask Before Delete preference.
However, you are unlikely to delete many disks from your 
library and should therefore, avoid disabling this preference.
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Tidy

The Tidy command in the Librarian menu scans the library
and removes all the disks that have been marked for 
deletion.  This is useful if you plan to delete many disk 
records.  Since you can collect all the marked deletes and 
update your library in one action!  

If you are in Auto Tidy mode and have previously marked 
disks for deletion and your next command is Cut or Clear 
then not only the selected items are deleted but also all the 
records that have been marked for deletion.
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Note: Tidy is a non-recoverable command and cannot be 
undone.

Copying and pasting

Copying in MacLibrarian works like any other application; 
you select a record and select the Copy menu item from the 
Edit menu.  If no records are selected then MacLibrarian 
attempts to copy whatever you have in the Search Area of 
the active window.

All records are copied as text tab-delimited.  This means that
they can be easily transferred to word processing packages 
and spreadsheets.  

Note: The Copy command should only be used for transfering 
small amounts of data.  If you need to transfer large 
amounts of data then see the chapter on "Exporting Your 
Library.".

Pasting in MacLibrarian is supported only in the Search 
Area.  This is to ensure the integrity of the library.

To copy records

1. Select the records to be copied.

You can select more than one record by keeping the 
Command key down and clicking the desired records.  
The records selected are highlighted.  If no records in the 
active window are selected then the text selected in the 
Search Area is copied to the clipboard.

2. Select Copy from the Edit menu.
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The highlighted records are copied to the clipboard in 
text tab-delimited form for insertion into your favorite 
word processor or spreadsheet.

To paste from the clipboard into the search area

1. Select the text in the Search Area.
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A quick method of selecting all the text in the Search 
Area is to press the Return or Enter key.  If there is 
nothing to select then a blinking vertical bar is displayed.

2. Select Paste from the Edit menu.

The text in the clipboard replaces the selected text.

MacLibrarian does not support copying or pasting of text in 
the Tree window.
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Chapter 7: Window Management

MacLibrarian has three windows for viewing 
disks and files records.  These are:

• Disk Window

• File Window

• Tree Window

The Disk and File windows allow you to 
manipulate the way the information is 
displayed and searched.  The Disk Window is 
the default window when the application is 
started.  The File window is used to show the 
entire list of files in the library.  This can be 
accessed by the Show Files menu item in the 
Windows menu.  The Tree window displays 
the contents of a disk in a tree format and is 
only displayed when requested by double-
clicking the appropriate disk or file record.

Disk and file 
windows

As described above there are two windows which let you 
manipulate the way the information is displayed.  Both 
windows are of standard type and you should feel 
comfortable with them.  However, there are a few 
differences such as the Search Area and the view titles. 

The view titles are displayed in both the disk window and 
file window.  The data for the view titles is the appear in the 
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respective columns.  The view titles may be renamed, 
hidden, rearranged and resized to suit your needs.  
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View Titles

Stamped Disk Unlocked Disk

Serial Number

Search Area

The titles are described in the following tables:

View title Description 

Num Serial number assigned to the disk.  

Stamped The one cent stamp icon shows that 
the disk has been electronically 
stamped (or marked).  

Volume Name The name of the disk.  

Create Date The date the disk was created.  

Modified date The date the disk was last modified.  

Locked The padlock icon shows that the disk
was locked when scanned.  

Size The amount of disk space used.  

Files The number of files scanned.  

Dir The number of directories scanned.  

Type The floppy icon or the hard disk icon
indicates the type of disk.  
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Table 1-Disk window view titles 
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View title Description 
Filename The name of the file which may be 

preceded by a StuffIt or Compactor 
icon to show it belongs to a 
compressed file.  

Vol# The serial number assigned to the 
disk.  

Volume Name The name of the disk.  

Type An icon representing an application, 
file or directory.  

Create Date The date the disk was created.  

Modified Date The date the disk was last modified.  

Type Signature The file signature.  

Creator Signature The creator signature.  

File size The size of the files scanned.  

App Mem The application memory size 
required.  

Version Information The version information if it exists.  

Table 2-File window view titles

The Search Area allows you to enter characters to search for a particular disk or file 
record.  To take advantage of the Search Area you need to have an ordered list in the 
first column such as the serial number.  Let us assume that you are looking for the 
90th record and you do not want to use the scroll bar.  Then simply enter "90" in the 
Search Area and you will notice that after entering the "9" the ninth disk record has 
scrolled to the top of the window; after entering the "0" the 90th disk record has 
scrolled to the top of the window.  This is useful when you are looking for a specific 
file but cannot remember how you spelled the filename or you are looking for a file 
or disk that you last modified two months ago.  As stated this only works when you 
have a sorted list.  However, there is nothing to stop you using it when you do not 
have a sorted list but the results of the search is not guaranteed (it depends on the 
search algorithm's ability to find a match).

Note There is a quick method of selecting text in the search area; simply press the 
Enter or Return key and all the text in the area becomes selected.
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Managing columns

As mentioned earlier the column (view title) may be 
renamed, hidden, rearranged and resized to suit your needs.  

Moving a column

The view titles are the titles for the respective columns.  The
display order of the columns can be changed.  If you have 
already tried a Sort from the menu then you would have 
noticed that the column being sorted gets moved to the first 
column.

To move a column 

1. Click and hold the mouse button on the view title of the column 
you want to move.

The cursor changes to the animated cursor shown on the left.  

2. Move the cursor to the new position while still holding 
down the mouse button.

The mouse button must be released in a view title area, 
otherwise the request for a change will be ignored.  The 
column appears in the new position.  

The column is inserted to the left of the position where 
the mouse button was released.  Therefore, when 
releasing the mouse button one position to the right the 
net effect will be no change.  To move the view title a 
single column to the right you have to move the view title
two positions to the right before releasing the mouse.

Note: If you are in Auto Sort mode and move the view title to 
the first column then a sort is performed.

Adjusting column 
widths

Placing your cursor on the edge of the column in the view 
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titles changes the cursor to a vertical bar with horizontal 
arrows.  You can now change the column width by selecting 
and dragging it to the new position.  
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To adjust the width of a column 

1. Select the column divider line (edge of column) in the 
view area .  

A vertical line is extended to the bottom of the window as
a guide and as an indication that you are changing the 
column width.  

2. Holding the mouse bottom down move the cursor 
horizontally and release at the desired location.

The column width is adjusted to the new width and all 
text is trimmed to fit within the column.  The text is 
trimmed when three dots are placed at the end of the 
visible text. 

Hiding columns

There are two methods to hide a column.  You can make the 
column width zero by adjusting the column width or double 
click the column title to change the attribute of the column.

To hide a column by using column dividers

You can hide columns that you are not interested in by 
dragging the right column divider line and placing it over 
the left column divider line of the column you wish to hide.  
A hidden column is shown by a thick divider line in the view
title area.  (This feature is similar to the one in Excel).
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To hide a column by view title

1. Double click the view title of the appropriate column.  

The following dialog is displayed.
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2. Click the Hide Item in the dialog box and click the Ok 
button.

The dialog is removed and the selected column is hidden.

Making hidden 
columns visible

To make a hidden column visible 

• Select the thick divider line in the view title area and drag
it to the right.  

This expands all hidden columns at that position.  If more
than a single column is hidden in one area than it will 
expand them.

Changing the title of 
a column (view title)

To change the column title (view title)

1. Double-click in the view title area.  

You will be presented with a dialog box showing the 
original name and new view name.  If this is the first time
you are changing the view title name then the new view 
name will be the same as the original name.
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2. Select the New View name and change the title.

3. Click Ok.

The dialog box is removed and the column is renamed.

Managing multiple 
windows

A window can be made the active window that is, brought to the front by 
selecting the window name from the windows menu.  

The disk and file windows are always available from the Windows menu.
To open or activate the File window, select the Show Files menu item in
the Windows menu.  To activate the Disk Window, select the Show 
Disks menu item from the Windows menu.  

If you close the Disk window MacLibrarian will give you the option of 
saving your data before closing the library.  

When a window is opened it is added to the Windows 
menu.  The Library name is added to each window to avoid 
confusion when you have multiple libraries open 
simultaneously.  When the window is closed, it is removed 
from the Windows menu.  

The contents of the clipboard can also be viewed.  No 
editing is allowed in the clipboard window.  To open the 
clipboard or bring the window to the front, select Show 
Clipboard from the Windows menu.  The Show 
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Clipboard command is disabled when the clipboard is 
empty.
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Tree window

Displaying a tree

To display the disk contents in a tree format, double-click on
the disk or file record.  MacLibrarian will load the disk 
contents from the library and display it as shown below.

If you double-click on a file record, the tree is expanded to 
show the file in the hierarchy of the disk record.  For ease of 
identification the file is hilited.  This lets you know where a 
file resides, without having to search manually.
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The left-hand of the tree window displays specific 
information about the highlighted icon in the tree.  This area 
is known as the 
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icon information area.  To display the information for a 
particular icon (disk, folder or file), select the icon.  The 
information is displayed in the icon information area.  This 
saves you switching back and forth between windows to get 
specific information about the file or disk records.

Displaying folders in 
the tree hierarchy

The plus icon  that appear in the folder indicates a folder 
that can be expanded.  The minus icon   indicates a folder 
that has been expanded and can now be collapsed.

A folder without a plus or minus sign indicates an empty 
folder.

Double-clicking on a folder with a plus icon expands the 
folder; that is, it displays the next level in the tree hierarchy. 
If you want to expand the entire folder and any folder 
within (that is, the entire tree hierarchy of the folder) then 
hold down the Command key and double-click the folder.  

To collapse a folder with a minus icon, double-click the 
minus folder while holding down the Command key.  To 
hide the contents of the folder double-click on it.  
Collapsing a folder removes the contents of the folder 
from the tree hierarchy.  

Double-clicking on a collapsed folder expands it to the 
next level in the tree hierarchy.  Double-clicking on a hidden
folder expands the content to show the entire hierarchy that 
was previously displayed.  

Displaying archive 
files in the tree 
window

Archives files are treated like folders with one exception, if 
the Expand Archive preference is enabled then the archive file is shown 
expanded to the first level.  All folders within the archive are treated as normal 
folders.  To get the archive to behave like a normal folder, disable the Expand 
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Archive preference.

Displaying file information in 
the tree window

Clicking on a folder or file displays information about that file in the icon 
information area on the left side of the tree window.  If the information in the icon 
information area is not fully visible, you can expand this area by moving the pointer 
to the right edge of the tool area and then clicking and dragging the edge.  
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At the moment there are two tools displayed in the tool area an arrow and an area 
tool.  The area tools does nothing at the moment (it will later).

Changing the display size of 
the tree

The Display menu item in the Preferences menu lets you change the way the tree is 
displayed.

The display size of the tree can be changed.  This is done by changing the default 
icon size and the default vertical and horizontal spacing between icons.

To change the vertical spacing, horizontal spacing or the icon size

1. Select Display from the Preferences menu.

A dialog is displayed giving you the option of changing the icon size, vertical 
shift and horizontal shift.
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2. Click in the check boxes to disable the check boxes.

Disabling the check boxes activates the editable fields.

2. Edit the editable fields as required.

Note that the sizes are number of pixels.

4. Click the OK button to make the changes, or click the Cancel button to ignore 
the changes.

The dialog box is removed and the tree is displayed with the new dimensions.
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Chapter 8: Sorting and searching

MacLibrarian has several ways for you to 
search or sort the contents of the Disk and File 
windows.  You can use the Librarian menu 
commands or use short cuts such as the 
AutoSort and the Search Area.

Sorting 

You can sort on any field of the records in the disk or file library.  
However, you must make sure that the appropriate window is active by 
clicking on it.  Depending on the active window, the appropriate sort fields
are made available in the hierarchical Sort menu.  As the window changes 
so will the hierarchical contents of the Sort menu.

To Sort using the menu commands

1. Select the desired window for the sort to be performed in.

2. Select the desired sort from the hierarchical Sort menu.

MacLibrarian displays an animated cursor while it is attempting to build a 
new Index file.  Upon completion of this activity the screen is redrawn 
with the sorted field in the first column.  

MacLibrarian always rearranges the display by displaying 
the sorted column as the first column.

AutoSort

You can also use the view titles to perform a sort.  This 
requires that the AutoSort preference, be enabled.  As you 
have probably already guessed moving the view title to the 
first column will sort the field being placed in the first 
column.  The AutoSort has no effect on any column except
the first.

Note: AutoSort is window specific preference setting.  That is 
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setting it in the Disk window will not set it in the File 
window.  If you want the feature enabled in both windows
then you have to set each window individually.
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To Sort using view titles.

1. Enable AutoSort from the Preferences menu.

The AutoSort menu item should now have a check mark 
beside it.

2. Select the view title you wish to have sorted

3. Drag the view title to the first column and release the 
mouse button.

MacLibrarian displays an animated cursor while it is 
attempting to build a new Index file.  Upon completion of
this activity the screen is redrawn with the sorted field in 
the first column.

Searching the 
contents of a window

As described earlier there are two main ways to search and the easiest and 
most straight forward way is to use the menu commands.  The Disk and 
File windows each have their respective fields identified for which a 
search is possible in the hierarchical menu Find.  The Disk or File 
window must be active for the hierarchical Find to be enabled.  

The advantage of searching from the menu is that you do not need a sorted
list in the first column.  MacLibrarian scans from the beginning of the 
library until it finds a match.  

To find from the menu

1. Select the window for which a search is desired.

2. Select the type of search from the hierarchical Find 
menu

A dialog similar to the one below is displayed.  The 
contents of the dialog will change depending on the type 
of search.  For example, Ignore case does not make 
sense when you are searching for a date.
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The Don't Find Button accepts all the information but 
does not start the search.  To start the search after 
clicking the Don't Find Button you can use the Find 
Again command from the Librarian menu.

The Cancel button will ignore all input entered and the 
dialog box is put away.  The Find Again menu item is not
made available.

3. After entering the search string and the desired case is 
chosen, click the Find button.

The dialog box disappears, MacLibrarian finds the first 
match and scroll the record to the top of the window and 
highlights the record.  

Finding the Next 
occurrence

Searching from the Find menu only displays and highlights 
the first occurrence.  To find other matches you need to use 
the Find Again menu item from the Librarian menu.  The 
criteria for the search depends on what you had entered and 
what choices you made in the last Search dialog.  You may 
repeat the Find Again command until there are no more 
matches.

Search area

The Search Area at the bottom left-hand corner of the 
window can also be used for searching but requires the first 
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column to be sorted.  However, the results are slightly 
different since the Search Area ignores all other possible 
matches in the field.  This is best explained by an example:

Let us assume you want to search for the filename 
"WINDOW" and the filename view title is sorted in the first 
column.  As you type each character in the word 
"WINDOW" in the Search Area you will notice that the 
screen scrolls.  When you enter 'W' the window scrolls to the
start of the Ws, when you type the second character 'I' the 
content of the window scrolls to the start of the WIs... and so
on.  I have never entered the full text of what I am 
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looking for.  I can find what I am looking for after a few 
characters typed.

Note: The Search Area is a case sensitive search.
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Chapter 9: Customizing MacLibrarian

The Preferences menu lets you to change the way MacLibrarian operates 
and behaves during your working session.  

The preference menu is now Library-specific and any new window that is 
created for a particular library has the same preference settings.  The only 
exception to this rule is the Auto Sort Menu preference which is window-
specific and the Cmd-Period Enabled preference which is session-specific.

Some preferences are not applicable in some windows since they increase 
the complexity of the application without adding value.

The changes to the preferences stay active during your working session 
and are saved with your library.  When the library is opened, the saved 
settings are restored.  

AutoSort

If the AutoSort is enabled, a sort is automatically performed 
when a column is moved and becomes the first column.  If 
AutoSort is disabled, a column can be rearranged without a 
sort being performed on the contents.  If you are unsure how
to move a column refer to Moving a column in Chapter 7.  

Moving a column (view title) from the first column to any 
other column has the same effect as moving the second 
column to the first.  MacLibrarian moves the first column to 
the position at which the mouse button was released and all 
columns are shifted to the left.  The second column now 
becomes the first and a sort is performed.

AutoSort is enabled when a check mark precedes the menu 
item and is disabled when there is no check mark present.

Note: AutoSort is a window specific preference setting.  That is,
setting it in the Disk window will not set it in the File 
window.  If you want the feature enabled in both windows
then you have to set each window individually.
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AutoTidy

When you delete a record from the disk or file window, 
MacLibrarian does not remove the record from the library 
but marks the record for deletion and dims its appearance.  
To 
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remove the record permanently you need to use Tidy.  This 
two step process can be bypassed by enabling the AutoTidy 
Preference.

Disk Record marked deleted

When AutoTidy is enabled the record is permanently 
removed; however, you are warned that you are in AutoTidy 
mode and are given the opportunity to change you mind.  
This warning can be disabled by setting the Ask Before 
Delete preference.

AutoTidy is enabled when a check mark precedes the menu 
command and is disabled when there is no check mark 
present.

FastScan

When Fast Scan is enabled MacLibrarian can scan many disks in a short
time.  However, Fast Scan does limit scans to the internal floppy drive.  
Disabling Fast Scan allows you to choose other drives such as Optical 
drives, CDs, Hard disks and floppies.  If you are unsure how to scan disks 
refer to Chapter 3 "Building a library".  

Fast Scan is enabled when a check mark precedes the menu command 
and is disabled when there is no check mark present.

Fast Scan enabled is the default mode of operation.  

Expanding Archives

If you use the StuffIt or the Compactor archive utility then 
you may have compressed many files into a single file.  
These files behave as any other file does, but you may not 
see the contents of the archive until you have started the 
archive application.  MacLibrarian allows the contents of 
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such files to be expanded and displayed as separate files in 
the library.  The expanded archives files are displayed in the 
File window with the StuffIt or Compactor icon preceding 
the name of the file.  The Tree window treats the archives 
files as a folder and displays it with the proper archive icon 
instead of the folder icon.  This feature is useful since it 
allows the contents of the archive to be viewed 
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like any other file and enabling you to quickly identify the 
file and where it resides.

If Expand Archives is enabled then all archives are expanded
when the disk is being scanned.  

If Expand Archives is enabled when a Tree window is 
opened or a folder expanded the archive expands 
automatically to show the first level of the archive.  If you 
double-click on the archive it does not collapse or hide the 
contents of the archive.  If you want to hide the contents of 
the archive then disable the Expand Archives preference in 
the Tree window.  Don't forget to enable it before doing 
further scans.

Expand Archive is enabled when a check mark precedes 
the menu command and is disabled when there is no check 
mark present.

MacLibrarian supports StuffIt, StuffIt Classic, StuffIt 
Deluxe and Compactor archives.

Cmd Period Enabled

If Cmd Period is enabled you can cancel a scan or update 
operation by using command period.  This is useful if you 
are scanning large disks or CDs.  

If you are Updating very large hard disks then you might 
want to disable this option since it keeps a copy of the 
previous scan in memory and only releases the memory 
when the update is completed.  This reduces the applications
memory requirements.

Stamp Disk

The Stamp Disk preference tells MacLibrarian if it should write an 
invisible document to the disk.  This operation is referred to as marking or 
stamping the disk.  If a disk is stamped, a one cent stamp is displayed in 
the Disk window under the stamped View title.  The stamped, invisible 
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document can be used to identify the disk by reading the disks serial 
number which is useful if you forget to write the serial number on the 
disk.

If the disk is not stamped a one cent stamp with a cross is displayed in the 
Disk window and no invisible document is written to the disk.  This may 
be due to the disk being locked or the Stamp disk preference being 
disabled.

Stamp Disk is enabled when a check mark precedes the menu item and is 
disabled when there is no check mark present.

Stamp Disk disabled, is the default mode of operation.  
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Ask Before Deleting 
record permanently

If Ask Before Delete is enabled MacLibrarian asks you for 
confirmation before deleting a record permanently.  This 
preference takes effect when you are deleting disk records 
and the AutoTidy preference is enabled.  

To bypass this additional level of protection during delete, 
disable Ask Before Delete.

Display Grid

This preference if enabled will draw grid lines in the Disk and File windows.  If you 
are running on a Mac+ and find the display to be slow, disable this preference to 
improve the performance.
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Changing the size of 
the tree

The Display preference sets the way the tree is displayed in the Tree 
window by allowing you to change the size of the icons and the spacing 
between them.  The default size for the icon and spacing between them is 
16 pixels.

Selecting the Display preference displays a dialog box which lets you 
change the icon size and the vertical and horizontal distances between 
them.

To change the icon size and the vertical and horizontal shifts
disable the appropriate check boxes and enter the new 
values.  Click the OK button to validate the changes and to 
redraw the tree with the new values.
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The preceding diagram shows the effect of changing all the 
parameters to 32 pixels.  For best results keep all the 
parameters the same size.

Filters

MacLibrarian now supports filters.  Filters are used to 
exclude certain files from being displayed or printed 
(including labels).  A typical file you might want to filter is 
the desktop file.  Its Creator is "ERIK" and its file Type is 
"FNDR".  You can look up the Creator and the file Type of 
the file you want to filter in the File window.

To add a filter

1. Select the Filter menu item from the Preference menu.  

A dialog box is displayed showing a list of filters 
( initially empty).  

2.  Enter the Creator signature and File Type and click the 
Add button. 

The filter is now part of the filter list.  

3 Check the Enable filter check box and click on the OK 
button.

MacLibrarian updates the display for all open windows 
MacLibrarian User Guide



Table of Contents 107

and removes all files from the display list that match the 
filter list.
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Chapter 10: Exporting Your Library

Exporting your data 

MacLibrarian allows you to export your library to a tab-
deliminated text file.  This is the preferred method for 
transferring large amounts of data (as opposed to using the 
clipboard).  You can Export either all the data associated 
with a window or just parts of it.  

You can export either the File or Disk window but not both 
at the same time.  If you have applied a filter to your library 
then the filter is still in effect when you export your data.

To export your library.

1. Select either the disk or file window.

2. Select the Export menu item in the File menu.

You will be presented with the export options dialog as 
shown below:

3. Select the options desired and click the OK button.

The export options dialog is removed and a standard file 
dialog is displayed.
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4. Enter a document name for the export data to be saved to.

5. Click the Save button.

The standard file dialog is removed and a progress dialog
is presented.

All your data is exported to a document as tab-delimited 
text.
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Chapter 11: Printing

Setting Margins

MacLibrarian allows you to set your margins for the page to 
be printed.

To set your page margins

1. Select the Page Setup menu item from the File menu.

You will be presented with the page setup dialog.

2. Change the margin values to suit your own needs.

The margin values are in inches and the default values 
are 1 inch from the left and right edge of the page and 1/2
inch from the top and bottom of the page.

3. Click the OK button.

Your new page margins have been set.

Printing selected 
items

MacLibrarian allows you to print either the selected items in
a window or all the items in the window.  

To print selected items
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1. Select  the window you desire to print and select the 
records you want printed.
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If you don't want any of the columns printed you can 
hide them as described in chapter 7 "Hiding columns".  
What you see is what gets printed, so format your 
columns as desired.  

2. Select the Print menu item from the File menu.

You will be presented with the standard print dialog with 
a "Print Hilited items only" check box at the bottom of 
the dialog.  This option is disabled if you try to print from
the Tree window since you cannot select more than one 
item.

3. Select the check box and click OK.

A dialog box showing the progress being made is 
displayed.

If you want to stop printing at any time, press the 
Command key and type a "." (period).

MacLibrarian prints only the visible columns and the items 
you have hilited.  

Printing disk library

To print the disk library 

MacLibrarian User Guide



Table of Contents 113

1. Ensure the window is active.

You may want to rearrange the disk window by using the 
view titles to suit your personal preferences.  In addition, 
may want the library sorted to allow you to search 
quickly through the printed library.

2. Select Page Setup from the File menu and set your 
preferences.
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If you are using an ImageWriter you may want to 
experiment with the Page margins, orientation, and the 
size of the columns to get the best results.

3. Select Print from the File menu.

A Print dialog box appears.  Depending on your printer 
you have, the dialog box may look somewhat different 
from the one shown below.

4. Click OK to start printing the library.

A dialog box showing the progress being made is 
displayed.

If you want to stop printing at any time, press the 
Command key and type a "." (period).

Printing the file 
library

Printing the file library is identical to printing the disk 
library except for the recommended Page Setup settings.

To print the file library 

1. Ensure the file window is active.
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You may want to rearrange the file window by using the 
view titles to suit your personal preferences.  In addition 
may want the file library sorted to allow you to search 
quickly through the printed library.
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2. Select Page Setup from the File menu and set your 
preferences.

If you are using an ImageWriter you may want to 
experiment with the Page margins, orientation and the 
size of the columns to get the best results.

3. Select Print from the File menu

A print dialog box appears.

4. Click OK to start printing the library.

A dialog box showing the progress made is displayed.

If you want to stop printing at any time, press the 
Command key and type a "." (period).

Printing a Tree 

To print a Tree 

1. Ensure the tree window is active.

You may want to rearrange the tree window by making 
sure the desired files and folders are visible.  You may 
also use the Display preference to set desired icon size 
and spacing.  Refer to the Display preference in the 
previous chapter.

2. Select Page Setup from the File menu and set your 
preferences.

You may want to set your orientation to portrait for best 
results.

3. Select Print from the File menu.

A print dialog box appears.  

4. Click OK to start printing the tree.
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A dialog box showing the progress made is displayed.

If you want to stop printing at any time, press the 
Command key and type a "." period.

Note: When printing a tree the Icon Information Area is not 
printed
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Appendix A: Registration and futures

Version 1.5.4 of MacLibrarian is being offered 
for distribution under the shareware 
philosophy.  You may try it on a trial basis for 
10 days and if you decide to use it after this 
initial trial period you must pay a registration 
fee of US $30.  Your registration entitles you to
a personnel key which unlocks the Label 
printing and future enhancements. 

I am very interested in hearing what you have 
to say about MacLibrarian, good or bad and 
what you would like to see added to this 
product.   Please take a few moments to give 
your views and suggestions for improvement 
in the registration form.

If you would like a printed manual then send a 
cheque for US $15.00 to cover printing and 
handling charges.  This is what it costs me and 
I prefer NOT to get into the printing business 
but if you need it I will do it. 

MacLibrarian User Guide



Table of Contents 119

MacLibrarian 1.5.4 Registration Form:

Mail To: Epsilon Systems, 
66 Pellan Way, 
Kanata, K2K 1J8, 
Canada.

Name:______________________________________________
_________
Company:___________________________________________
_________
Address:____________________________________________
_________
City:________________________   State:____________
Zip:___________________         

Country:_________________
Phone: (____) _____ - _______

Product QTY Price Amount
--------------------------------------------------------- ------- ----------

--------
MacLibrarian 1.5.4 Registration Fee $30.00
Printed documentation $15.00
--------------------------------------------------------- ------- ----------

--------

     Total ________
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____________________________________________________
____________________

The Things I most disliked about MacLibrarian are:

The things I most liked are:

I think you should add the following features:

MacLibrarian has been used on a MAC____ running system 
version ______.

Your support for shareware is greatly appreciated.
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